[コメント]:<>((c)2017-2021、Aidynamics、Inc。All Rights Reserved。)

モデル

モデルは、ユーザーがプロジェクトを作成し、モデルを学習させる場所です。そのため、学習に使用される[NMLファイル](JP-NML-overview.md)の作成もここで行います。現状、モデルには「Overview/概要」、「Project Data/プロジェクトデータ」、「Model Editor/モデルエディタ」、「Train/学習」、「A/B test/テスト」のサブタブが存在します。

ex:空のモデルタブ(学習前の状態)

プロジェクトの作成と選択

Neopulse® Managerでは、プロジェクトごとに目的の異なるAIモデル群を束ねて管理します。左上にあるプロジェクトセレクタにてプロジェクトを選択します。プロジェクトセレクタの上には「プロジェクトの追加」ボタンがあります。これにより、ユーザーは新しいプロジェクトを作成し、名前や説明に追加します。新しいプロジェクトを追加すると、それは自動的にプロジェクトセレクタに追加されます。

例:プロジェクトセレクタ

プロジェクトを編集または削除するには、プロジェクトセレクタで[Overview/概要]タブに移動します。プロジェクトのタイトルの横の「鉛筆」ボタンからプロジェクトタイトル・説明の変更、「ゴミ箱」ボタンからプロジェクトの削除が可能です。

データセットを追加する

プロジェクトのモデルの学習には入力データが必要です。Neopulse® Manager内においてAIモデルを作成するには、データセットNMLファイルがプロジェクトに登録される必要があります。プロジェクトにデータセットを追加するには、「Project Data/プロジェクトデータ」タブを選択し移動します。ここで、「Add Dataset to Project/プロジェクトにデータセットを追加」ボタンをクリックすると、Neopulse® Managerにアップロード済みの全データセットのタイトルが表示されます(データセットをアップロードする方法を参照](MNGR-DataSets.md))。目的のデータセットを選択して[追加]を押してプロジェクトに追加します。

データセットがプロジェクトに追加されると、[プロジェクトデータ]タブに表示されます。

例:プロジェクトの添付データセット

このヘッダの下には、「Add view/ビューの追加」ボタンと自動的に作成されたデフォルトビューがあります。Neopulse® Manager内では、ビューはNMLファイルの作成プロセスに必須項目です。「Add view/表示の追加」ボタンをクリックにより、新しいビューを追加することができます。「ゴミ箱」ボタンを押すことで、ビューの削除も可能です。

ビューエディタ内では、ユーザーはデータセットのCSVファイルを確認し、列の扱いを変更できます。列毎に3つのオプション(INP、OUT、N/A)の選択可能です。INPは、NMLファイルのソース・コンストラクトの入力ブロックに含まれ、OUT列は出力ブロックに含まれます。n/aオプションを持つ列は、NMLから完全に除外されます。ビューに変更が加えられたら、ユーザーは「保存」ボタンを押して編集を続けることができ、「保存と続行」ボタンを押すと、表示エディタを終了するか、「戻る」ボタンを押してすべての変更を元に戻して表示を終了します。

例:ビューエディタ

ニューラルネットワークの編集

NMLファイルが学習ジョブで使用されるためには、さらに2つの構成が必要です。これらは[アーキテクチャ](nml-Architietemude.md)と[学習](nml-train.md)です。これらは、AIモデルのニューラルフローとトレーニングパラメータを定義します。トレーニングに使用されるNMLファイルを作成するには、「モデルエディタ」タブに向かい、「ニューラルネットワークデザインの作成」ボタンをクリックしてください。ボタンを押すと、ユーザーは新しいデザインに名前と説明を追加でき、さらにドロップダウンメニューからデータセットビューを選択できます。これらの情報を入力すると、ユーザは、「Visual Model Editor/ビジュアルモデルエディタ」・「NML Editor/エディタ」・「Back/戻る」ボタン間を行き来でき、ニューラルネットワーク設計を開始することができます。

Visual Model Editor

ビジュアルモデルエディタは、トレーニングのために送信されるべきNMLファイルのアーキテクチャ構成を設計するためのグラフィカルUIを提供します。このツールを使用すると、ユーザーは[NML](NML-Overview.md)を用いる必要はなく、アーキテクチャ構成は自動生成されます。もちろん上級者は編集も可能です。

Visual Model Editorタブには、右側の青い歯車のアイコンがあります。そこでは、ユーザーは「グリッドにスナップする」またはドットと行の間で背景の種類を切り替えるなど、エディタ設定を変更できます。設定選択後、ビジュアルモデルエディタはそれらの変更が反映されます。デフォルトでは、ビジュアルモデルエディタは、"auto"ブロックを介して接続されている選択ビューからの入力/出力を表示します。接続を削除するには、接続の対応するゴミ箱アイコンを使用します。また、入力、出力、またはレイヤブロックを選択して「削除」キーを押すことで削除できます。

エディタに新しいコンポーネントを追加するには、「入力」、「登録」、「コア」、「共通」、「操作」、「時系列」、「出力」の下に注意してください。/ニューラルネットワーク設計の説明各メニューには、誤って削除された場合のレイヤブロックまたは入出力ブロックが含まれています。メニューからオプションを選択すると、それをマウスに追加します。ここで、クリックで画面上のどこにでも削除できます。クリックしている間、メタキー(すなわちMac上のコマンド "コマンド)を押しながら、同じ選択ブロックの複数のインスタンスをドロップすることができます。これらのブロックのパラメータは、それらをダブルクリックして編集できます。コンポーネントがユーザーの満足度に設定されたら、1ブロックの右端から別のブロックの左端にマウスをドラッグしてそれらを接続します。これを使用して、入力をレイヤブロック、レイヤブロック、他のレイヤーブロックへのレイヤブロック、および出力ブロックへのレイヤブロックに接続するために使用できます。

例:ビジュアルモデルエディタと例示的なneuralflow

NOTE: This particular neuralflow is not necessarily recommended, and is meant to display a sample of the available Keras layers and modifications to their parameters.

ニューラルネットワーク設計が完了したら、デザインを保存するために画面上部の「戻る」ボタンを選択するだけです。これは、新しいニューラルネットワーク設計が他の以前に作成されたデザインと一緒に表示されるベース "Model Editor"タブにユーザーに戻ります。ただし、ユーザーがソース/列車の構築物を変更して、バッチサイズやエポックの数などのパラメータの一部を編集したい場合は、「Visual Model Editor」タブの横にある「NMLエディタ」タブに向かいます。次のセクションで説明します。Visual Model EditorからNMLエディタへの切り替えは、NMLエディタのアーキテクチャー・構文内の構築されたNeuranrFlowを説明するNMLコードを自動的に生成します。

NMLエディタ

NMLの書き方に精通しているユーザーの場合、NMLエディタはあなたのための強力なツールかもしれません。さらに、ユーザーがNMLファイルの自動生成されたソースと列車の構成を変更したい場合は、NMLエディタはそのようなカスタマイズが発生することができる唯一の方法です。NMLエディタ自体には4つのセクションがあります。

  • Oracle Mode Selector: a drop-down menu allowing users to select the overarching AI task for the oracle. The selected Oracle Mode will appear at the top of the Source NML section. More information can be found here.

  • Source NML: an NML Source construct which has been automatically generated to match the selected dataset view. The view upon which the section is built can be changed by clicking on the blue text on the right of the Source NML header. This section can also be collapsed by toggling the arrow to the left of the "Source NML" header.

  • Architecture NML: an NML Architecture construct which defines the neuralflow of the models to be trained. It uses an auto layer by default, which is only currently supported for oracle("mode")="regression" or "classification". Users may need to manually define this section for other Oracle Modes or if a specific model design is desired.

  • Train NML: an NML Train construct which defines the parameters of the models' training process. If users wish to set their own parameters, they can do so in this section, but no editing is required for training to occur successfully. This section can be collapsed by toggling the arrow to the left of the "Train NML" header.

すべての希望の変更が追加されたら、ユーザーはNMLエディタの右下にある[NMLの保存]ボタンを選択する必要があります。このボタンは、アーキテクチャ構成からビジュアルモデルエディタで表示されるべきニューラルフローも生成されるので、ユーザーがビジュアルモデルエディタで見たい変更を加える場合は、必ずそれらの変更を保存してください。ビジュアルモデルエディタタブ。NMLが保存されると、画面上部の[戻る]ボタンをクリックすると、以前に作成された他のデザインと一緒に「モデルエディタ」タブに新しいニューラルネットワーク設計が表示されます。

Example: the NML Editor with an auto-generated architecture construct matching the example shown in the Visual Model Editor

![](../ images / manager / nmlditor.png)

モデルの学習

モデルデザインが「モデルエディタ」タブで完了したので、プロジェクトセレクタに表示されているプロジェクトに対してモデルを作成して学習させることができます。プロジェクトのモデルを訓練するには、「Train/学習」タブに向かいます。そこで、「モデルの列車」ヘッダーの下で、ユーザーは2つのドロップダウンメニューを表示します。左はモデルデザインを選択するために使用され、右は学習処理を担うNeopulse® Studioマシンを選択するために使用されます(これらは[DevOps](Mngr-Devops.md)]タブから管理されます)。

2つのドロップダウン選択後、「Train/学習」ボタンを押すと、学習ジョブが表示されます。このセクションでは、各学習ジョブの送信タイムスタンプとステータスが表示されているため、学習進行中、学習完了時のエラーの有無を確認できます。

NOTE: The job name is generated as a function of the project name, model design name, and a random hash.

注:ジョブ名は、プロジェクト名、モデル設計名、ランダムハッシュ関数を組み合わせて生成されます。

例:Train/学習 Tab

Neopulse® Managerでは、AIモデルの学習に加え、AIモデルをプロジェクトにインポートすることも可能です。AIモデルをインポートする場合は、「Overview/概要」タブに向かい、「PIMのインポート」ボタンを選択します。次にファイルフォーマットをONNX、Keras、Pytorch、PIMファイルから選択します。

AIモデルのテスト

学習ジョブが実行されている間、AIモデルの学習進捗のグラフィカル表示は「概要」タブに表示されます。グラフにはモデルのメトリック値の推移が表示され、グラフは、X軸に「iteration/繰り返し」、Y軸に「メトリック値」があらわされます。Y軸のスケールは、「Scale-Y」ボタンを使って変更することができ、リニア、ログスケールのいずれかを選択できます。デフォルトでは、プロジェクトに含まれるすべての学習ジョブが表示されます。同様に、すべてのメトリックがデフォルトで表示されます。

例:完成したトレーニングジョブの概要タブのグラフ

訓練を受けたモデルは、「A/B test/テスト」タブ内のデータを使用して比較することもできます。「New test/新しいテスト」ボタンをクリックすると、AIモデルを比較評価するためのデータセットを選択できます。データセットは「プロジェクトデータ」タブからプロジェクトに添付する必要があります。次に、評価対象の最大5つのPIMを選択します。ステータスが「TEST_COMPLETED」になると、結果はグラフで表示されます。

例:A / Bテストパラメータ選択画面

例:完成したテストの表示